Latency
Incident Report for Realm Status Page
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 12:59 EDT
Investigating
We are currently investigating issues of latency in the processing of payroll, or in printing reports or checks in Realm and Realm Accounting.
Posted Apr 22, 2024 - 12:38 EDT
This incident affected: Realm and Realm Accounting.