Slowness
Incident Report for
Realm Status Page
Resolved
We are still monitoring Realm closely to make sure it is operating exceptionally.
Posted
Jan
13
,
2026
-
08:22
EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Jan
12
,
2026
-
20:00
EST
Update
We are continuing to investigate this issue.
Posted
Jan
12
,
2026
-
16:44
EST
Investigating
Some sites may be experiencing slowness and time outs in Realm, our team is working to address this as soon as possible.
Posted
Jan
12
,
2026
-
16:44
EST
This incident affected: Realm and Realm Accounting.
×
Subscribe to Incident
Subscribe to updates for
Slowness
via . You'll receive .