Investigating an issue with Realm images failing to load. Also, some users are experiencing issues with logging in.We will post updates here.

Incident Report for Realm Status Page

Resolved

This incident has been resolved.
Posted Apr 04, 2025 - 10:37 EDT

Update

We are continuing to investigate this issue.
Posted Apr 04, 2025 - 09:28 EDT

Investigating

We are currently investigating this issue.
Posted Apr 04, 2025 - 08:57 EDT
This incident affected: Realm.